package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:https://\S+)|(?:sc-domain:[^/\s]+))$`)
var str = `https://www.foo.com/
https://www.foo.com/bar/
sc-domain:www.foo.com
However the below entries should fail
htps://www.foo.com/
https:/www.foo.com/bar/
sc-domain:www.foo.com/
sc-domain:www.foo.com/bar
scdomain:www.foo.com
sc-domain:www.foo.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}