re = /\$.+?\$/m
str = '$aslfabvaw18684rd,W@18396$
sacvndu
$89ajcan219*@($&@($^)!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end