$re = '/^\+?[0-9][0-9()-\s+]{4,20}[0-9]$/im';
$str = '555-555-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);