package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1}`)
var str = `section[new][1][description]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}