$re = '~(https?://([-\w\.]+)mydomain.com([^"]*))~';
$str = 'https://see.my-cool-site.here.mydomain.com/maybe-more-here/but-not-important/yes';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);