re = / (?:0b[10]+|[0-9]+|'[^']+'|"[^"]+")/m
str = ' 12 0b110110 \' \' " " "str this is a test string" \'str this is a test string\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end