$re = '/^[\d\s\+\-]+$/i';
$str = '+91 9766554433';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);