package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<userConfiguration\s*id=(?<Id>[.]|[^<]*)>\s*<user\s*FullName=\"(?<FullName>[.]|[^\"]*)\"\s*LoginName=\"(?<LoginName>[.]|[^\"]*)\"\s*Group=\"(?<Group>\d{1,3})`)
var str = `<userConfiguration id="myId">
<user FullName="" LoginName="User-1-LoginName" Group="0" Level="0" StartingDate="2020-08-04" ExpiredDate="2021-02-05" salt="4Bn0RL/qMZeBFIck+o+oHCVLtRwJzgxN4tAUV4zhCUMZSVNpdhkgguPuLCt4/k4L" data="dXBIUUqmYsJ5llcDKHGbYahM8YETEpkx31n+ridQKZD6QtxtuBtgsD6+kkI0YGRleV17O3aN4ieCCjJ3l1IdEOvD4jjb8NTFCr4vXZHh2K+hhl9LyisKopbkNbo6ExHC4f1RC4RNJDTcHrTp7SqetpSYzvQ/Tn8/0r/PLGlbOn2ihbTtZkC+r4QSKjAtE21sB0bvBrCd8yyI37vbLqfJrXs0mVyll63AdNcfzNWoMETNEIZWGiWyRw+nOlC8gA3ag4909dR6rk7vX3lBSNgUBwegcTeJyznpZLq5yppj5vTQe0kZZbbfxuFcDEktyH4O"/>
<encodedData><![CDATA[[header]
Description=User Configuration file for WTT_ENC
Version=4
User=eckrodt
Timestamp=05.08.2020 13:42:48
Tool=M1ServiceCenter
LicenseOption=1
[body]
IZ4J7wFwyNRZn9syvJSQhJFo8Oipq15O4Ybe5a/sv65uqXI3d6lDY1rb5IrtF/r95PegytemC+6lxuQxwptSjKF2gRUZB3vN
Q8HXbP3OWh2gImJHjc6Yz+Tw6f+D+Herq/Plr6LMh2in1mKfiuof]]></encodedData>
</userConfiguration>
<userConfiguration\s*id=(?<Id>[.]|[^<]*)>\s*<user\s*FullName=\"(?<FullName>[.]|[^\"]*)\"\s*LoginName=\"(?<LoginName>[.]|[^\"]*)\"\s*Group=\"(?<Group>\d{1,3})`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}