$re = '/.*page=([1-9]{1,3})/';
$str = '../section/subsection/page=394/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);