$re = '/(\/)(.*?)\1/';
$str = '"This is /a/ silly ex/amp/le of what I /me/an."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);