re = /^\s*\/(?:\/|\*)[@#]\s+sourceMappingURL=data:(?:application|text)\/json;(?:charset[:=]\S+;)?base64,(.*)$/m
str = '//# sourceMappingURL=data:application/json;base64,<!--insertbase64encodedsourcemapdatahere-->
i++;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end