re = /"(?=((?:[^"\\]+|\\.)*))\1"/m
str = '"a string" ... "another \\"string\\"" ... "yet another \\"string" ... "failed string\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end