const regex = /^https:\/\/(my\..*|accounts\..*|maya\..*\/reports\/(mymessages|favorites)|maya\..*\/account\/notification|info\..*\/management\/generalpages\/pages\/(personalfolder|registration|change_password|userssearchindex|security%20search)\.aspx).*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/(my\\..*|accounts\\..*|maya\\..*\\\/reports\\\/(mymessages|favorites)|maya\\..*\\\/account\\\/notification|info\\..*\\\/management\\\/generalpages\\\/pages\\\/(personalfolder|registration|change_password|userssearchindex|security%20search)\\.aspx).*', 'gmi')
const str = `https://my.tase.co.il
https://accounts.tase.co.il
https://maya.tase.co.il/reports/mymessages
https://maya.tase.co.il/reports/favorites
https://maya.tase.co.il/account/notification
https://info.tase.co.il/Management/GeneralPages/Pages/PersonalFolder.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Registration.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Change_Password.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/UsersSearchIndex.aspx
https://info.tase.co.il/Management/GeneralPages/Pages/Security%20Search.aspx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}