$re = '/^(?:[A-Z]{1,3}[0-9]{1,10}(?::(?=[A-Z]))?){1,2}$/m';
$str = 'A1
A1:C4
AB:AB
A1:A1:
1:1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);