$re = '/(.+)\(.*?\]\s(.+)|(.*)/';
$str = 'Xenoblade Chronicles X (USA) [Loadiine] something more
Xenoblade Chronicles X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);