import re
regex = re.compile(r"^(?=.*\d)(?=.*[a-zA-Z])([a-zA-Z\d]{10}$)", flags=re.MULTILINE)
test_str = ("sasas12212\n"
"211212jknn\n"
"2121212122\n"
"csdcdcdcdc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")