$re = '/([[a-z]&&[def]])|[[a-z]&&[^bc]]/mv';
$str = 'abcdefghijklmnopqrstuvwxyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);