$re = '/^[0-9]{2,6}$/m';
$str = '9999999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);