re = /^\/posts\/[0-9]+$/m
str = '/posts/3829
/posts/921
/posts/anylink
/posts/create
/posts/1a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end