$re = '/(.*(?<=\.)\d{3})(\d+)(\s[AP]M)/m';
$str = '09-Jun-21 04.40.45.898000 PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);