using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=https:\/\/strm.yandex.ru\/kal\/)(.*?)(?=\/)";
string input = @"
""content_url"": ""https://strm.yandex.ru/kal/probusiness_cv_supres/probusiness_cv_supres0.m3u8?from=unknown&partner_id=188262&target_ref=https%3A//yastatic.net&uuid=42b7c9a63d2c656ab5dc8c5ec0934d6f&video_category_id=1017";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}