#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^## COL(?:\n(?!## ).*)*"
Local $sString = "## COL" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueA", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueB", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueC", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 2, "key1": "value1", "key2": "valueA", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 3, "key1": "value1", "key2": "valueA", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 3, "key1": "value1", "key2": "valueB", ... "keyN": "valueN"}" & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
"{ "Id": n, "key1": "value1", "key2": "valueZ", ... "keyN": "valueN"}" & @CRLF & _
"## USA" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueA", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueB", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueC", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 2, "key1": "value1", "key2": "valueA", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 3, "key1": "value1", "key2": "valueA", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 3, "key1": "value1", "key2": "valueB", ... "keyN": "valueN"}" & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
"{ "Id": n, "key1": "value1", "key2": "valueZ", ... "keyN": "valueN"}" & @CRLF & _
"## ESP" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueA", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueB", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 1, "key1": "value1", "key2": "valueC", ... "keyN": "valueN"}" & @CRLF & _
"{ "Id": 2, "key1": "value1", "key2": "valueA", ... "keyN": "valueN"}" & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
" ." & @CRLF & _
"{ "Id": n, "key1": "value1", "key2": "valueZ", ... "keyN": "valueN"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")