$re = '/(https?:\/\/)([^\/]*)(\/?\S*)/m';
$str = 'http://google.com/
https://www.long.sub.domain.com/path/222/333?junk=text
Not URLs. http://domain.com/..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);