$re = '/^([A-Z]+)(\d+)([A-Z]+)(\d\d)(.{6})(.)(.)$/m';
$str = 'C37S25FF0000TD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);