# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:downloads|s[0,1][0-9])\.upd\.kaspersky\.com$"
test_str = ("\n"
"s00.upd.kaspersky.com\n"
"s01.upd.kaspersky.com\n"
"s02.upd.kaspersky.com\n"
"s03.upd.kaspersky.com\n"
"s04.upd.kaspersky.com\n"
"s05.upd.kaspersky.com\n"
"s06.upd.kaspersky.com\n"
"s07.upd.kaspersky.com\n"
"s08.upd.kaspersky.com\n"
"s09.upd.kaspersky.com\n"
"s10.upd.kaspersky.com\n"
"s11.upd.kaspersky.com\n"
"s12.upd.kaspersky.com\n"
"s13.upd.kaspersky.com\n"
"s14.upd.kaspersky.com\n"
"s15.upd.kaspersky.com\n"
"s16.upd.kaspersky.com\n"
"s17.upd.kaspersky.com\n"
"s18.upd.kaspersky.com\n"
"s19.upd.kaspersky.com\n"
"downloads.upd.kaspersky.com\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.