re = /=\(((?!=\(|\)).)*(?R)?((?!=\(|\)).)*\)/m
str = '=(rjd=(du)dj) =(when) =(tyyr)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end