#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "~~TemplateStart~~[\s\S]+?~~TemplateEnd~~"
Local $sString = "<table cellSpacing="0" cellpadding="0" id="~~TableIDClass~~" class="ContainerTable">" & @CRLF & _
" <thead> " & @CRLF & _
" <tr class="header">" & @CRLF & _
" <td class="TableTitle">~~TableName~~</td>" & @CRLF & _
" </tr>" & @CRLF & _
" </thead>" & @CRLF & _
" <tbody class="~~TableIDClass~~ ClickableTableBody">" & @CRLF & _
"~~TemplateStart~~" & @CRLF & _
" <tr data-type="~~Data-Type~~" data-id="~~Data-ID~~" data-date="~~Data-Date~~" data-cost="~~Data-Cost~~" class="TableText clickable AddMee">" & @CRLF & _
" <td nowrap class="DateColumn">~~Date~~</td>" & @CRLF & _
" <td nowrap class="JarColumn"></td>" & @CRLF & _
" <td nowrap class="CategoryColumn">~~Category~~</td>" & @CRLF & _
" <td nowrap class="NotesColumn">~~Note~~</td>" & @CRLF & _
" <td nowrap class="CostColumn">~~DefaultCostDot~~$~~Cost~~</td>" & @CRLF & _
" </tr>" & @CRLF & _
"~~TemplateEnd~~" & @CRLF & _
" </tbody>" & @CRLF & _
" <tfoot>" & @CRLF & _
" <tr>" & @CRLF & _
" <td norap colspan="5">$<span class="TableTotal"></span></td>" & @CRLF & _
" </tr>" & @CRLF & _
" </tfoot>" & @CRLF & _
"</table> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")