re = /<!--([\w\W]+)-->([\w\W]*)<!--\s?\/\1-->/m
str = '<!-- block -->
My content
<!-- / block -->
<!-- empty --><!-- / empty -->
<!-- inline -->My content<!-- / inline -->
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end