$re = '/ferr[a]?[r]?[i]?[y]?[e]?[t]?/m';
$str = 'ferr
ferra
ferrr
ferri';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);