re = /{#(.*?)#}/m
str = '{#Hi#}, Please {#don\'t#} {#mark#} this {#question#} as {#duplicate#}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end