$re = '/((?<=\")?)--help(?(1)(?!\"))/m';
$str = 'find --help "This is a --help"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);