re = /(0|\+98)?([ ]|-|[()]){0,2}9[1|2|3|4]([ ]|-|[()]){0,2}(?:[0-9]([ ]|-|[()]){0,2}){8}/m
str = '0--9|()1-(1-(1-(1-(1-(1-(1-(1-('
# Print the match result
str.scan(re) do |match|
puts match.to_s
end