package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]+):\/\/([^/]*)\/([^/]*)\/(.*)\.git`)
var str = `https://gitlab.com/example/test_backend.git`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}