#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Banana\b.*\b(\d{6})\b"
Local $sString = "Banana lmasfh asfjhas jhona uh3 a y u3u3 303303 ajksdfkas 3jk5hk" & @CRLF & _
"" & @CRLF & _
"Banana lmasfh asfjhas jhona uh3 a y u3u3 202202 ajksdfkas 3jk5hk" & @CRLF & _
"" & @CRLF & _
"Apple lmasfh asfjhas jhona uh3 a y u3u3 101101 ajksdfkas 3jk5hk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")