re = /filename="?([^.]+)/m
str = 'filename="John_wheeler 11041997 resume.pdf";
filename="Kujal_newResume(1).pdf";
filename=JohnKrasinski_Resume.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end