# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=TITLE)(?!\s*Direct Submission)[\S\s]*?(?=JOURNAL)"
test_str = (" TITLE The Identification of Novel Diagnostic Marker Genes for the\n"
" Detection of Beer Spoiling Pediococcus damnosus Strains Using the\n"
" BlAst Diagnostic Gene findEr\n"
" JOURNAL PLoS One 11 (3), e0152747 (2016)\n"
" PUBMED 27028007\n"
" REMARK Publication Status: Online-Only\n"
"REFERENCE 2 (bases 1 to 462)\n"
" AUTHORS Behr,J., Geissler,A.J. and Vogel,R.F.\n"
" TITLE Direct Submission\n"
" JOURNAL Submitted (04-AUG-2015) Technische Mikrobiologie, Technische\n"
" TITLE OtherDirect Submission\n"
" JOURNAL Submitted (04-AUG-2015) Technische Mikrobiologie, Technische")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.