$re = '/\s(?![^\[]*\])/m';
$str = 'string1[1] string2[2] string3[3] [4 5]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);