re = /^((?:(?:0)[0-9])|(?:(?:1)[0-2])|(?:(?:[1-9])))(?:\/|\\)(\d{4})$/m
str = '12/02/2020
02/2020'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end