# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\S+\sas\s*\(\s*((?:\n.*)*?)\n\s*FROM\b"
test_str = ("with \n"
"qry_1 as ( \n"
" SELECT ID, \n"
" NAME\n"
" FROM ( ... other code...\n"
"),\n"
"qry_2 as ( \n"
" SELECT coalesce (table1.ID, table2.ID) as ID,\n"
" NAME\n"
" FROM (...other code...\n"
"),\n"
"qry_3 as (\n"
" SELECT id.WEATHER AS WEATHER_MORN,\n"
" ROW_NUMBER() OVER(PARTITION BY id.SUN\n"
" ORDER BY id.TIME) AS SUN_TIME,\n"
" id.RAIN,\n"
" id.MIST\n"
" FROM (...other code..\n"
")")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.