import re
regex = re.compile(r"(?<FirstPart>(?:<div>.*?){4})|\G(?<!^).*\K(?<SecondPart>(?:<\/div>.*?){4})", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<!DOCTYPE html>\n\n"
"<html>\n\n"
" <head>\n\n"
" </head>\n\n"
" <body>\n\n"
"<div>\n\n"
"<div>\n\n"
"<div>\n\n"
"<div>\n\n"
"<div>\n\n"
"<div>\n\n"
"<div>\n\n"
"<div>\n\n"
"</div>\n\n"
"</div>\n\n"
"</div>\n\n"
"</div>\n\n"
"</div>\n\n"
"</div>\n\n"
"</div>\n\n"
"</div>\n\n"
" </body>\n\n"
"</html>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")