$re = '/^.*(.)\1.*$/m';
$str = 'mdmdkomsddkmsaomco
idhdioqhd dwoq o
dwlmklwqm kxqm
dmwmdkqmd11q';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);