$re = '/^(?=.{3,60}$)[a-z]+(?:\.[a-z]+)+$/mi';
$str = 'label
label.favourite
label.favourite.pineapple';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);