#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:\d{2}\/\d{4}|\d{2}(?:\/\d{2}\/\d{4})?)\b"
Local $sString = "12/12/2014." & @CRLF & _
"" & @CRLF & _
"I'm also trying to satisfy 12 and 12/2014." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"the response value 10 (from here I want to extract 10)" & @CRLF & _
"the response value 10/12/2014 (from here I want to extract 10/12/2014)" & @CRLF & _
"the response value 08/2015 (from here I want to extract 08/2015)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")