package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\p{L}|\p{N}|\s]`)
var str = `Hello Привет 你好 123_456 "Âlvarö`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}