$re = '/\(DOG,([^()]*)\)/m';
$str = '(CAT,A)(DOG,C)(MOUSE,D)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);