re = /^(?:(?<domain>[\w\-]+?)\.(?<parent>[\w\-\.]+)\s*$)/m
str = 'boa.midlandls.commloanservices.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end