re = /^IPAddress$|^Hostname$|^(([a-zA-Z0-9]|[a-zA-Z0-9][a-zA-Z0-9\-]*[a-zA-Z0-9])\.)*([A-Za-z0-9]|[A-Za-z0-9][A-Za-z0-9\-]*[A-Za-z0-9])\/[a-zA-Z0-9]+$
/m
str = 'IPAddress
Hostname
Other
FQDN
foo.com/bar
foo.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end