#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:LLC_BI__Stage__c[\S\s\r]*LLC_BI__Status__c|LLC_BI__Status__c[\S\s\r]*LLC_BI__Stage__c)"
Local $sString = "<displayedFields>" & @CRLF & _
" <field>LLC_BI__Amount__c</field>" & @CRLF & _
" <isFieldManaged>false</isFieldManaged>" & @CRLF & _
" <isRequired>false</isRequired>" & @CRLF & _
"</displayedFields>" & @CRLF & _
"<displayedFields>" & @CRLF & _
" **<field>LLC_BI__Status__c</field>** " & @CRLF & _
" <isFieldManaged>false</isFieldManaged>" & @CRLF & _
" <isRequired>false</isRequired>" & @CRLF & _
"</displayedFields>" & @CRLF & _
"<displayedFields>" & @CRLF & _
" <field>LLC_BI__lookupKey__c</field>" & @CRLF & _
" <isFieldManaged>false</isFieldManaged>" & @CRLF & _
" <isRequired>false</isRequired>" & @CRLF & _
"</displayedFields>" & @CRLF & _
"<displayedFields>" & @CRLF & _
" **<field>LLC_BI__Stage__c</field>**" & @CRLF & _
" <isFieldManaged>false</isFieldManaged>" & @CRLF & _
" <isRequired>false</isRequired>" & @CRLF & _
"</displayedFields>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")