package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^☒.+`)
var str = `☐I am good
☐This is sky
☒Nice to meet you
☐hello world`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}