package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)PJ\s?[=:]\s?\{(.*[\r\n].*?)*?\};`)
var str = `h=function(a,b){var c=this.index.fh(a);b&&(c=Math.min(this.index.Bc(),c+1));return MJ(this,c,this.index.po(c),0)};g.h.rs=function(){var a;if(a=this.Cd()&&!(0,window.isNaN)(this.l))a=this.index,a=(a.o?a.g[a.Ia]:-1)!=this.l;return a};g.h.xe=function(){return!0};g.h.tc=function(){return!1};g.h.fr=function(){return this.indexRange.length+this.initRange.length};
g.h.Wt=function(){return his.indexRange&&this.initRange&&this.initRange.end+1==this.indexRange.start?!0:!1};var PJ={yF:function(a,b){var c=a[0];a[0]=a[b%a.length];a[b]=c},It
:function(a){a.reverse()},yp:function(a,b)
{a.splice(0,b)}};g.p(RJ,g.kF);g.h=RJ.prototype;g.h.Mf=function(){return Mb(this.g,function(a){return a.info.video?2==a.info.video.projectionType:!1})};g.h.Nf=function(){return Mb(this.g,function(a){return a.info.video?3==a.info.video.projectionType:!1})};g.h.Le=function(){return Mb(this.g,function(a){return a.info.video?4==a.info.video.projectionType:!1})};g.h.ji=function(){return Mb(this.g,function(a){return a.info.video?1==a.info.video.stereoLayout:!1})};g.h.wS=function(a){var b=a.getElementsByTagName("Representation");if(0<a.getElementsByTagName("SegmentList").length||0<a.getElementsByTagName("SegmentTemplate").length){this.A=!0;this.B||(this.B=new ska);wk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}